• 0
Sign in to follow this  
Boris Progrebnyak

sound sound.ogg not found

Question

Hello, I am trying to add custom environment sounds and ambient sounds to my exile server with triggers, but am having no luck so far. 
The problem I am having is i always get the Sound sound.ogg not found when activating the trigger in game.

20181120045110_1.thumb.jpg.c4d2186af21ade30f74c7e12072d7cad.jpg

Spoiler

//Custom Sounds
class CfgEnvSounds
{
    sounds[] = {};

    class snow
    {
        name = "snow";
        sound[] = {sounds\snow.ogg,0,0,1};
    };
	
	class wolves
    {
        name = "wolves";
        sound[] = {sounds\wolves.ogg,0,0,1};
    };

};

 

 

I've added the section above to my description.ext. Both .ogg files are placed within the server mpmissions\Exile.chernarusredux\sounds.

My triggers also look like this

20181120050134_1.thumb.jpg.78bd2409dc5b917c5171579aa4003146.jpg20181120050146_1.thumb.jpg.c23bc9a9e0c4b88b290eb6e115a2c953.jpg

 

I honestly hope i'm not missing something simple because im still learning arma syntax, or maybe this feature is just broken? I have no clue if anyone could help that would be awesome!

 

Share this post


Link to post
Share on other sites

3 answers to this question

  • 1

I had issues with sounds working in Exile in the past. I think the class you are trying to use will only affect existing sounds for the map. The way I got sounds to work in-game is by using the following method:

class CfgSounds 
{
    sounds[] = {};
	class snow
	{
		name = "snow";
		sound[] = {\sounds\snow.ogg, 1.0, 1};
		titles[] = {""};
	};
	
	class wolves
    {
        name = "wolves";
        sound[] = {\sounds\wolves.ogg, 1.0, 1};
		titles[] = {""};
    };
};

And then I haven't used map triggers to play the sounds, but I used scripts to execute the sound using this method:

_soundPath = [(str missionConfigFile), 0, -15] call BIS_fnc_trimString;
_soundToPlay = _soundPath + "sounds\snow.ogg";
playSound3D [_soundToPlay, player, false, getPosASL player, 1, 1, 500];

Although it is important to mention that the 3D sound will play for anyone within the radius and not for a single client. More information about editing settings for the sounds volume can be found here:
https://community.bistudio.com/wiki/playSound3D

Edited by Beowulfv

Share this post


Link to post
Share on other sites
  • 0

I will try that then, but Ive also been looking up a way to replace the environment sound by using this: 

class CfgEnvsounds

	{
		tracks[]={snow.ogg};
	class snow
		{
		name = "snow";
		sound[] = {sounds\snow.ogg, db+10, 1.0};
		};
	};

I wasn't even able to load onto my server at that point, but do you think that this is maybe another route to explore as well as your fix? My goal is to have snow falling, but the environment match the snow

Share this post


Link to post
Share on other sites
  • 0

These are the top posts I found on Bohemias forums about manipulating environment sounds. I personally have only messed with sounds for actions, like alarms and other such sounds. 

https://forums.bohemia.net/forums/topic/185049-problems-when-setting-up-customized-environment-sounds/
https://forums.bohemia.net/forums/topic/187014-disable-ambient-sounds-replace-with-custom-sounds/

Edited by Beowulfv

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.