• 0
Sgt Smash

Arma 3 update making server keys broken?

Question

63 answers to this question

  • 0

It MAY be that since the NEW version of ARMA supports BY DEFAULT v3 of the signatures and all of us (basically) are using v2 of it, this is the issue.

See:  https://dev.arma3.com/post/techrep-00043

 

DSUtils

    Added: Support for signatures version 3
    Added: A new startup parameter -v2 to generate v2 signatures (
v3 is now the default)

 

 

While this is for DSUtils, the GAME may be EXPECTING v3 of the signatures as the keys WILL BE v3 BY DEFAULT.

 

Just a thought....

;)

 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Z80CPU said:

It MAY be that since the NEW version of ARMA supports BY DEFAULT v3 of the signatures and all of us (basically) are using v2 of it, this is the issue.

See:  https://dev.arma3.com/post/techrep-00043

 

DSUtils

    Added: Support for signatures version 3
    Added: A new startup parameter -v2 to generate v2 signatures (
v3 is now the default)

 

 

While this is for DSUtils, the GAME may be EXPECTING v3 of the signatures as the keys WILL BE v3 BY DEFAULT.

 

Just a thought....

;)

 

Thanks for the reply

So would the "new startup parameter -v2" fix this? and if so do i have to do it client side or serverside?

Share this post


Link to post
Share on other sites
Advertisement
  • 0
30 minutes ago, Sgt Smash said:

Thanks for the reply

So would the "new startup parameter -v2" fix this? and if so do i have to do it client side or serverside?

Just tested the -v2 start parameter and still the same problem. Guess we have to wait for a fix from bohemia .....

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Not Work

-ip=xxx -port=2312 -cfg=epochconfig\basic.cfg -autoinit -v2 -mod=@Epoch;@Enhanced_Movement -servermod=@EpochHive;@obfusqf;@A3EAI;@infiSTAR_A3 -profiles=E:\TCAFiles\Users\drt_support\38\ -config=epochconfig\server.cfg

Share this post


Link to post
Share on other sites
  • 0

even setting verifysignature=0 seems not to work for me... rpt file ends with:

20:49:42 Error a1 reading file 'config\\basic.cfg'
20:49:42 Error a1 reading file 'config\\server.cfg'

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, ausHaus said:

even setting verifysignature=0 seems not to work for me... rpt file ends with:

20:49:42 Error a1 reading file 'config\\basic.cfg'
20:49:42 Error a1 reading file 'config\\server.cfg'

verifySignatures                       = 0;

But i would advise against it, it makes your server vulnerable for cheaters !

Edited by El Rabito

Share this post


Link to post
Share on other sites
  • 0

You did not read the link nor what I put.  The '-v2' is ONLY for DSUtils!  NOTHING ELSE!

I was merely proposing a POSSIBLE REASON why it may be not working.  And if disabling the signatures is not working, this makes me think there is an issue with the ARMA executable itself, as you should be able to disable the signatures, which means if this is TRULY a signature issue, then disabling would 'fix this'.  As this is NOT the case, this makes me look at the EXE.  And as @El Rabito stated and I agree 100%, do NOT disable the check!

By doing such can cause ALL SORTS OF TROUBLE!  From cheating to trashing your DB!  The check ENSURES EVERYBODY is using the EXACT SAME MODS!  Otherwise, one player is using v2 of XYZ mod and another is using v14 of XYZ mod and some hacker is using a cheat mod call XYZ.  ;)

 

As luck would have it, my server's HDD died this morning so I am unable to test/offer any 'real' solutions until I either 'fix' my hdd or replace it.

 

Share this post


Link to post
Share on other sites
  • 0
Spoiler

 

1 hour ago, Z80CPU said:

You did not read the link nor what I put.  The '-v2' is ONLY for DSUtils!  NOTHING ELSE!

I was merely proposing a POSSIBLE REASON why it may be not working.  And if disabling the signatures is not working, this makes me think there is an issue with the ARMA executable itself, as you should be able to disable the signatures, which means if this is TRULY a signature issue, then disabling would 'fix this'.  As this is NOT the case, this makes me look at the EXE.  And as @El Rabito stated and I agree 100%, do NOT disable the check!

By doing such can cause ALL SORTS OF TROUBLE!  From cheating to trashing your DB!  The check ENSURES EVERYBODY is using the EXACT SAME MODS!  Otherwise, one player is using v2 of XYZ mod and another is using v14 of XYZ mod and some hacker is using a cheat mod call XYZ.  ;)

 

As luck would have it, my server's HDD died this morning so I am unable to test/offer any 'real' solutions until I either 'fix' my hdd or replace it.

 

With verify signatures = 0 I can connect to server np, in Arma launcher all mods are green

Spoiler

image.thumb.png.064c097727a021b1d35534fd66307fd6.png

verify signatures = 1 all red :(

Spoiler

unknown.png?width=365&height=301

considering my player base I don't have to be afraid of hacking and cheating XD

Edited by Brenner

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.