lachev

Help with errors (ExileZ)

6 posts in this topic

I installed successfully an Exile server, logged in and played for awhile. Now I'm trying to add zombies to the server and followed the instructions from the kuplion's ExileZ mod github.

So the current mods placed in the main server folder are: @Exile, @ExileServer and @Zombies-and-Demons

and then I also have exilez_mod.pbo in the @ExileServer\addons folder

I edited the mission file Exile.Tanoa and added to the mission.sqm: 

addons[] = {"exile_client","A3_Ui_F","Ryanzombies","ryanzombiesfunctions"};

I'm running the server with that command: 

./arma3server -cfg=@ExileServer/basic.cfg -config=@ExileServer/config.cfg -autoinit -mod=@Exile\;@Zombies-and-Demons\; -servermod=@ExileServer\; >> serverlog.rpt

and after all of this I'm getting the following error:

21:03:20 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.Ryanzombies, ryanzombiesfunctions
21:03:20 Mission Exile.Tanoa: Missing 'description.ext::Header'
21:03:20 Starting mission:
21:03:20  Mission file: Exile (__cur_mp)
21:03:20  Mission world: Tanoa
21:03:20  Mission directory: mpmissions\__cur_mp.Tanoa\
21:03:20 Missing addons detected:
21:03:20   Ryanzombies
21:03:20   ryanzombiesfunctions
21:03:20 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.Ryanzombies, ryanzombiesfunctions
21:03:20 Mission Exile.Tanoa: Missing 'description.ext::Header'
21:03:20 Starting mission:
21:03:20  Mission file: Exile (__cur_mp)
21:03:20  Mission world: Tanoa
21:03:20  Mission directory: mpmissions\__cur_mp.Tanoa\
21:03:20 Missing addons detected:
21:03:20   Ryanzombies
21:03:20   ryanzombiesfunctions
21:03:20 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.Ryanzombies, ryanzombiesfunctions

 

Edit: And this is the List of Mods checkup, showing on the server's startup:

mods.jpg

 

Do you guys have an idea what could be messed up?

 

Edited by lachev

Share this post


Link to post
Share on other sites

Clarification: I downloaded and loaded Ryan's zombies mod, but I didn't added any modules from it to the mission file with the editor.

As I said above, I only added:

addons[] = {"exile_client","A3_Ui_F","Ryanzombies","ryanzombiesfunctions"};

to the mission.sqm.

Do I have to open the mission file with the editor and place some modules from the 'zombies-and-demons' mod too? 

This is not explained in the exilez's installation guide.

Share this post


Link to post
Share on other sites
Advertisement

Hello @lachev,

The 'mission.SQM' has a REFERENCE to this mod.  Either use your ORIGINAL mission.sqm (the one BEFORE you loaded that mod) OR MANUALLY remove it from the mission.sqm.

ARMA is STUPID about how it does things.  If I load 5 mods and open a BLANK map, ARMA may 'insert' 3 of the 5 mods in the mission file when I just SAVE A EMPTY MAP, even though I did not use those mods!

I have had this happen to me MANY TIMES in SP.

In the future, NEVER load your mission file UNLESS you are adding objects to the map.

 

So, what you need to do:

#1 - Use a 'backup' mission.sqm instead of your current one.

#2 - Manually edit your current mission.sqm and manually remove ALL references to that mod.  Do note, you will probably have to renumber some sections.  If you mess that up, the map will not even load.  Here is a link that will automatically renumber those items for you:

https://www.exilemod.com/topic/26993-deleted-content/

Why is it listed as deleted?  I do not know, but the link still works.

 

And it is quite clear that you violated the BIGGEST RULE in such matters:  NO BACKUP

ALWAYS make a backup BEFORE MAKING ANY CHANGES!

 

:)

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks mate!

I actually found the reason for that error and it's because the folder "Addons" inside @Ryanzombies is uppercase (and linux is case sensitive). After renaming it to lowercase - it worked! 

So that's that.

Anyway thanks for your time and help!

Share this post


Link to post
Share on other sites

Please note that General Discussion is not for support. In future please post in the relevant thread for the addon in question.

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.