Sign in to follow this  

You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.exile_client

2 posts in this topic

Working with a friend who just today bought an ArmaHosts server and am attempting to run Exile on it.

I've followed multiple guides when it comes to server setup, but I always end up back at the same error (See Title). This error is posted repeatedly in my Server's .rpt files, and only shows up when someone tries to join the server. The person attempting to join the server sees nothing but the "Connecting..." Screen.

Here's some more information.

@Exile and @ExileServer are both in the server's primary directory.

The Mission Cycle aspect of the server.cfg reads as follows.


// MISSIONS CYCLE (see below)
class Missions
class Exile
template = Exile.Altis; // Never include the .pbo in this line
difficulty = ExileRegular; // ExileRegular or ExileHardcore
};            // An empty Missions class means there will be no mission rotation

missionWhitelist[] = {

}; //an empty whitelist means there is no restriction on what missions' available


The Command Line reads as follows.


-port=2462 -Autoinit -MaxMem= "-servermod=@ExileServer" "-mod=@Exile" -profiles=ARMAHOSTS -config=ARMAHOSTS\server\server.cfg -cfg=ARMAHOSTS\server\basic.cfg "-name=armahosts" -Server

I have the latest version of Exile installed on my computer, as does my friend. I've tried both a physical download from the website and the Steam Workshop DL.

We are using no other mods asides Exile, and are using the default Exile.Altis map.

The start mission.sqm reads


class Mission

I'm officially at a loss. Exile is on the server, and is apparently being activated. Clients show no errors, only endless errors in the server's .rpt logs.


Edit: Here's what the .rpt logs look like before anyone joins.


e |       true |             GAME DIR | 31f89051969e29ea553203c32ca7972501c7b61b |  92db45c3 | orange

19:12:09                                      Arma 3 Malden |                 argo |       true |             GAME DIR | d8d3ac60c3a99f8414a094d0591c65eea7efc8fd |  e2934170 | argo

19:12:09                                        Arma 3 Jets |                 jets |       true |             GAME DIR | 408eb80d493aa11fd0d3b8516f65c06596e2b14d |  2a311e2c | jets

19:12:09                                        Arma 3 Apex |            expansion |       true |             GAME DIR | e458e8b4066613b11f951911ee8d525c9f2f98aa |  a9afa646 | expansion

19:12:09                                    Arma 3 Marksmen |                 mark |       true |             GAME DIR | 2a255977a9b3a0180e2aa427c1fca640e5c0fe7f |  f1016c78 | mark

19:12:09                                 Arma 3 Helicopters |                 heli |       true |             GAME DIR | 6a714914a9be47e5fde481c2a28288af05aa6687 |  6cb72e94 | heli

19:12:09                                       Arma 3 Karts |                 kart |       true |             GAME DIR | 4581dd3a8ab3b5b7864eabded04f77c864edc4b4 |  3e38263e | kart

19:12:09                                        Arma 3 Zeus |              curator |       true |             GAME DIR | 2f79d7e68f01c426656a12e210984bfd580117be |  e210394d | curator

19:12:09                                             Arma 3 |                   A3 |       true |            NOT FOUND |                                          |           | 

19:12:09 ==========================================================================================================================================================================================================

19:12:09 InitSound ...

19:12:09 InitSound - complete

19:12:09 PhysX3 SDK Init started ...

19:12:09 PhysX3 SDK Init ended.

19:12:11 core\skyobject\skyobject.p3d: No geometry and no visual shape

19:12:11 a3\data_f\krater.p3d: No geometry and no visual shape

19:12:11 a3\data_f\koule.p3d: No geometry and no visual shape

19:12:12 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.


19:12:12 Loading movesType CfgGesturesMale

19:12:12 Creating action map cache

19:12:12 Animation a3\anims_f\data\anim\sdr\gst\gestureempty.rtm not found or empty

19:12:12 MovesType CfgGesturesMale load time 39 ms

19:12:12 Loading movesType CfgMovesMaleSdr

19:12:12 Reading cached action map data

19:12:13 MovesType CfgMovesMaleSdr load time 1166 ms

19:12:13 a3\characters_f\proxies\flag.p3d: No geometry and no visual shape

19:12:13 Initializing Steam server - Game Port: 2462, Steam Query Port: 2463

19:12:13 Steam AppId from steam_appid.txt: 107410

19:12:14 Connected to Steam servers


Edit: Issue fixed. Armahost specific issue. Had to manually tell it to enable the command line I wanted it to run. Now I'm onto database issues.

Edited by Borg184

Share this post

Link to post
Share on other sites

Hello @Borg184,

I did not read/look at all of your spoilers, I did look at one:

You cannot play/edit this mission; it is dependent on downloadable content

This is a EASY problem to fix!


For example:

You edited the map and you started by having 5 mods loaded.  You make your changes, then save it.

When it is played, ONLY 4 mods are actually used.  ARMA says 'Hold on big boy!  My Mission file says I am supposed to have FIVE MODS, not FOUR!'  Then ARMA gives you that error message.

So you need to remove that mod that is referenced in your mission file.  Before you do this, MAKE A BACKUP OF THE FILE!!!


So that you will know, the same thing happens in SP missions too, except you get a different error message and you will be unable to pull that mission into the editor UNTIL the 'bad stuff' has been removed from the mission.sqm BY HAND.


I would HIGHLY recommend you set up a profile for JUST THE SERVER, and select this profile EVERY TIME you edit the map.  This way, it will NEVER happen again!


Get this and FOLLOW DIRECTIONS as it WILL make this process a lot EASIER!





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.