• 0
SleePyHollow150

Unknown Issue Causing Server Crash

Question

Hi All,

Starting to give up regarding server crashes. It's a shame to see our server, which has started to get really popular, crashing and losing players.

I've attached an RPT from our latest crash (~5 mins ago). The server sometimes goes nearly 2 weeks without a crash and then can crash twice in a day... the inconsistency to it and lack of error codes is making it difficult for me to see any cause. I've reinstalled ArmA on our server, as well as the mods. Maybe I'm missing something obvious but your help would be massively appreciated.

RPT: https://pastebin.com/Kguhygi0

Kind Regards,

Mark

Edited by SleePyHollow150

Share this post


Link to post
Share on other sites

16 answers to this question

Advertisement
  • 0

You need to give some of these errors attention. Not saying it will definitely fix your problem but, until they are cleared you won't know.

 0:19:22 Error in expression <ffectCreate ["ColorCorrections", 2500];
SUPER_PPEffect ppEffectAdjust [1, 1, -0.>
 0:19:22   Error position: <SUPER_PPEffect ppEffectAdjust [1, 1, -0.>
 0:19:22   Error Undefined variable in expression: super_ppeffect
 0:19:22 File \KA_Flashbang\init.sqf [SUPER_fnc_InitFlashBang], line 2
 0:20:16 Error in expression <(ammo1+ammo2)>
 0:20:16   Error position: <ammo1+ammo2)>
 0:20:16   Error Undefined variable in expression: ammo1
 0:20:16 unable to compile MFD condition '(ammo1+ammo2)'
 0:21:35 "DMS ERROR :: Attempting to spawn static base with file ""saltflatsbase"" after it has already been spawned!"
0:32:53 File '@RwG_Addon_Mosquito_Series\addons\rwg_addon_choppers_mozzie.pbo' not found.

It's a good idea to take a pause and check your server report after each change/edit/addon/script whatever to check if it's causing issues.

Fix these first and then send us a new report if it crashes again

 

Share this post


Link to post
Share on other sites
  • 0

I can't figure out what this stems from

0:20:16 Error in expression <(ammo1+ammo2)>
 0:20:16   Error position: <ammo1+ammo2)>
 0:20:16   Error Undefined variable in expression: ammo1
 0:20:16 unable to compile MFD condition '(ammo1+ammo2)'

 

Share this post


Link to post
Share on other sites
  • 0

Try using notepad++ feature to search in all files and folders or any other program you have that does the same for those words

Share this post


Link to post
Share on other sites
  • 0

remember to also unpack any pbo's in your @exileserver folder as it could be something in there...

Share this post


Link to post
Share on other sites
  • 0

Notepad++ can search in PBO's as well.  Keep in mind that the script that's causing the error can be in many locations - mission file, @Exile\addons folder, @AnyMod, etc.  Use the search in files functions in several places, the code is there somewhere.  I'd suggest simplifying the search at first.  I'd start with "ammo1" and see where that's being called.

Share this post


Link to post
Share on other sites
  • 0

No search results for "ammo1" in anything other than the RPT logs :(

Edit: I take that back. In archived versions of my server, "ammo1" is mentioned in the CBA_A3 mod, in the cba_common.pbo file. I'll check the new versions that have been released but I'm guessing it'll be in the latest update of CBA.

Edited by SleePyHollow150

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.