1547 posts in this topic

Don't get me wrong, I really like it.. just doesn't make any since why it doesn't work. I'm pretty good at installing and troubleshooting mods. Just couldn't get this to work all the way. before for I gave in, the notifications were back to working, its just the map marker locations stopped being displayed. I mean it would show 1 or 2 then any new missions, nothing.

Edited by geekm0nkey
spelling

Share this post


Link to post
Share on other sites
Advertisement

soooo. DId I miss a post about Mission07? His last update about it was wayyyy back in August. Did it get released and I'm not seeing it? Or did it fade into the ether?

Share this post


Link to post
Share on other sites

had a few issues since installing Napf, missions sometimes spawn without markers and also sometimes the AI spawn inside buildings with no inside so become impossible to kill.

Anyone had this or has a fix

 

cheers

  • Like 1

Share this post


Link to post
Share on other sites
On 21/01/2018 at 3:40 PM, red_ned said:

had a few issues since installing Napf, missions sometimes spawn without markers and also sometimes the AI spawn inside buildings with no inside so become impossible to kill.

Anyone had this or has a fix

 

cheers

Had the missing marker issue for along time now and not seen any fixes around unfortunately.  We use DSHouses to eliminate some of the non enterable buildings

 

Share this post


Link to post
Share on other sites
9 minutes ago, Razor77 said:

Had the missing marker issue for along time now and not seen any fixes around unfortunately.  We use DSHouses to eliminate some of the non enterable buildings

 

its like the spawn safe position isn't properly functioning, I will go down the DMS path further to replace VEMF

cheers

  • Like 1

Share this post


Link to post
Share on other sites
On 1/23/2018 at 10:59 AM, Razor77 said:

Had the missing marker issue for along time now and not seen any fixes around unfortunately.  We use DSHouses to eliminate some of the non enterable buildings

 

im using this ported to desolationredux on chernarusredux. Mod is installed and configured properly. I also have the missing map marker issue. First mission creates map marker just fine, after that no additional markers show. 

The missing map marker thing is definitely a bug, maybe related to certain maps?

Edit: marker issue went away not sure why.

However i still cant seem to get a mission to complete..

 

 

Edited by Robbhimself

Share this post


Link to post
Share on other sites

Hi, 

Need help/advise to get VEMF working. 

Seems that VEMF is not working well when server is to much busy : missions never finish... I added specific script so mark AI on map, to be sure every single bots is dead. Also added log in :

  • DynamicLocationInvasion.sqf
// Wait for Mission Completion
_h = [ _nts, _this0 ] ExecVM ( "killedMonitor" call VEMFr_fnc_scriptPath );
//waitUntil { if ( scriptDone _h ) then { true } else { uiSleep 1; false } };
waitUntil {
	uiSleep 10;
	[ "DynamicLocationInvasion", 1, format [ " -> mission %1 : sleeping for 10 seconds...", _ln ] ] ExecVM ( "log" call VEMFr_fnc_scriptPath );
	scriptDone _h
};
[ "DynamicLocationInvasion", 1, format [ "mission in %1 has been completed!", _ln ] ] ExecVM ( "log" call VEMFr_fnc_scriptPath );
  • killedMonitor.sqf
if ( ( count _a ) > 0 ) then
        {
                _k = 0;
                _cnt = count _a;
                _kp = round ( ( ( [ [ "missionSettings", _m ], [ "killPercentage" ] ] call VEMFr_fnc_config ) select 0 ) / 100 *_cnt );
                while {true} do
                        {
                                scopeName "while";
                                _k = 0;
                                { if ( ( ( damage _x ) isEqualTo 1 ) OR ( isNull _x ) ) then { _k = _k + 1 } } forEach _a;
                                [ "DynamicLocationInvasion", 1, format [ "%1 dead over %2 (<%3)", _k, _cnt, _kp ] ] ExecVM ( "log" call VEMFr_fnc_scriptPath );
                                if ( _k < _kp ) then { uiSleep 10 } else { breakOut "while" };
                        };
                [ "DynamicLocationInvasion", 1, format [ "%1 dead over %2 (>%3)", _k, _cnt, _kp ] ] ExecVM ( "log" call VEMFr_fnc_scriptPath );
        };

This is the log I get when kill all AIs : 

Spoiler

IT07: [VEMFr] Launcher -- SYSTEM: /// booting up VEMFr v0752.5 (Exile) \\\
IT07: [VEMFr] Launcher -- SYSTEM: Headless client support: DISABLED
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> debugMode'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> maxGlobalMissions'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> sayKilledName'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> aiCleanUp >> removeLaunchers
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> missionSettings >> DynamicLocationInvasion >> heliPatrol >> enabled'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> missionSettings >> DynamicLocationInvasion >> killPercentage'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> Exile >> crateMoney
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> missionSettings >> DynamicLocationInvasion >> allowCrateLift'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> timeOutTime'
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> Exile >> aiMode
IT07: [VEMFr] Overrides -- INFO: Overriding 'CfgVemfReloaded >> Exile >> aiMoney
IT07: [VEMFr] checkLoot -- INFO: validating VEMFr config classes...
IT07: [VEMFr] checkLoot -- INFO: All classnames are valid! :)
IT07: [VEMFr] missionTimer -- INFO: global mission-limit is set at: 3
IT07: [VEMFr] missionTimer -- INFO: enough players online (1) and server FPS (47.0588) is above 20. Starting missionTimer...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: invading Abdera...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: invading Negades...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: 0 dead over 10 (<7)
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: 0 dead over 10 (<7)
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: 2 dead over 10 (<7)
IT07: [VEMFr] DynamicLocationInvasion -- INFO: 4 dead over 10 (<7)
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: 5 dead over 10 (<7)
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO: 7 dead over 10 (>7)
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
IT07: [VEMFr] DynamicLocationInvasion -- INFO:  -> mission Abdera : sleeping for 10 seconds...
...

killPercentage is set to 65%.

According to log :

  • at least 7 bots over 10 were killed, which is enough to finish mission
  • 7 dead over 10 (>7) comes from log in killedMonitor, outside of the while loop (meaning loop is endded, and script should end just after that)
  • mission Abdera : sleeping for 10 seconds... (from DynamicLocationInvasion) means that waitUntil loop never ends...

Is it some kind of bug with waitUntil?

 

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.