Rod Serling

AVS - Advanced Vehicle System

718 posts in this topic

Execute the following query on your exile MySQL database:

ALTER TABLE vehicle  
ADD ammo text  
NOT NULL;  
UPDATE vehicle SET ammo='[]'

 

Screenshot.png.3c71067b39c5dbd8c310a156c8889c8a.png

how to fix?

Share this post


Link to post
Share on other sites
Advertisement
On 10/30/2018 at 11:30 AM, zol said:

Execute the following query on your exile MySQL database:

ALTER TABLE vehicle  
ADD ammo text  
NOT NULL;  
UPDATE vehicle SET ammo='[]'

 

Screenshot.png.3c71067b39c5dbd8c310a156c8889c8a.png

how to fix?

tell me how to add correctly ...Execute the following query on your exile MySQL database:

ALTER TABLE vehicle  
ADD ammo text  
NOT NULL;  
UPDATE vehicle SET ammo='[]'

Share this post


Link to post
Share on other sites

How and where can I change ammo related DB insert of a newly created persistent vehicles to prevent DB related errors?
Or maybe completely cut out ammo related code, since I don't use militarized vehicles at all...?

ALTER TABLE vehicle  
ADD ammo text  
NOT NULL;  
UPDATE vehicle SET ammo='[]'

The above code, only changes the already created persistent entries and must be done manually via sql query,
but when some of the persistent vehicles destroyed , new ones automatically spawned with their ammo data empty (see the attached screenshot , two bottom lines) and not with " [] " entry. Which creates AVS error
 

"AVS ERROR - INVALID MAGAZINE SAVED IN DATABASE: "
 "AVS ERROR - Magazines should be saved an array. Blank entries should be: [] Verify your database."

    

GLWga6h.png
 

Edited by Chernaruski

Share this post


Link to post
Share on other sites

I'm having hard times finding this annoying bug, that I think is somehow related to AVS spawning a new vehicle. 1 out 3 times , sometimes 1 out of 5 times server stuck on init (locked) and spits error.  Very hard to track since it have no consistency , but imho its related to AVS spawning a new vehicle , after one of the vehicles gets destroyed. 

First error is related to the AVS and incorrect creation of a value in DB , the ammo column empty instead of  empty array [ ].   

6:02:20 "AVS ERROR - INVALID MAGAZINE SAVED IN DATABASE: "
 6:02:20 "AVS ERROR - Magazines should be saved an array. Blank entries should be: [] Verify your database."

This one I pretty much ignore since it have no impact on gameplay (I don't use vehicles with ammo ) and server just loading with RPT error nothing else. This error never stopped server from loading.

The second ones is the one I get every time server is stuck in init state:
 

 6:02:24 "getSpawnedVehicleTracker: RoadCars"
 6:02:24 "getSpawnedVehicleTracker: RoadTrucks"
 6:02:25 "AVS ERROR - INVALID MAGAZINE SAVED IN DATABASE: "
 6:02:25 "AVS ERROR - Magazines should be saved an array. Blank entries should be: [] Verify your database."
 6:02:25 "AVS ERROR - INVALID MAGAZINE SAVED IN DATABASE: "
 6:02:25 "AVS ERROR - Magazines should be saved an array. Blank entries should be: [] Verify your database."
 6:02:25 Error in expression <s, rectangular _this, -1]};


if (_this isEqualTypeArray [[], 0, 0, 0, false]) e>
 6:02:25   Error position: <isEqualTypeArray [[], 0, 0, 0, false]) e>
 6:02:25   Error isequaltypearray: Type Number, expected Array
 6:02:25 File A3\functions_f\Misc\fn_getArea.sqf [BIS_fnc_getArea], line 30
 6:02:31 "SC/BIS_fnc_log: [BIS_fnc_preload] ----- Scripts initialized at 49800 ms -----"


I can't find what is behind this error. Its clear to me that when it gets to AVS init getSpawnedVehiclesTracker: RoadTrucks its gets stuck.
Could it be bugged vehicle that can't be spawned ? Could it be some deprecated BIS or exile legacy command that is used in my version of AVS 1.4.4 ?

Would appreciate your help with this.

-  FULL RPT (pastebin)
-  the AVS version I use

Share this post


Link to post
Share on other sites
On 3/8/2019 at 10:12 AM, Chernaruski said:

First error is related to the AVS and incorrect creation of a value in DB , the ammo column empty instead of  empty array [ ].   


6:02:20 "AVS ERROR - INVALID MAGAZINE SAVED IN DATABASE: "
 6:02:20 "AVS ERROR - Magazines should be saved an array. Blank entries should be: [] Verify your database."

This one I pretty much ignore since it have no impact on gameplay (I don't use vehicles with ammo ) and server just loading with RPT error nothing else. This error never stopped server from loading.

Reinstall this mod using insstructions and "Execute the following query on your exile MySQL database" disabling safe mod in MySQL. And it's work!)) Very awsome mode. Thanks!

Edited by Ro1and

Share this post


Link to post
Share on other sites
On 3/10/2019 at 2:58 PM, Ro1and said:

Reinstall this mod using insstructions and "Execute the following query on your exile MySQL database" disabling safe mod in MySQL. And it's work!)) Very awsome mode. Thanks!

It only fixes current vehicles in DB. Next time AVS will spawn new vehicles with empty ammo cell, and you will get the same rpt error again.

Still looking for assistance with my problem.

Update: Fixed I think, I've just set permanentlyDeleteTime = 0; so the exile remove completely the deleted vehicles from DB. Looks like AVS was having troubles with it.

Edited by Chernaruski

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.