• 1

MySQL Error: Unable to locate extDB2 extension


Hello Guys :)

We have the Problem that extDB2 doesn't work. The Error is "MySQL Error: Unable to locate extDB2 extension".

Hope anyone can help us!

Share this post

Link to post
Share on other sites

6 answers to this question

  • 0

moved to Problems subforum



That probably means that you are missing some files like extDB2.dll


you need to install Vcredist 32 bit 2010/2013




Edited by SpiRe

Share this post

Link to post
Share on other sites
  • 0

You need to download   extDB2.so

Extract the file from the rar file its will be located in Linux/@extDB2/extDB2.so
Copy this to your @ExileServer directory


Then you can check you have the requirements by typing

ldd ./\@ExileServer/extDB2.so

Paste the output from
ldd ./\@ExileServer/extDB2.so

Most likely you are missing 32bit version of ttb

apt-get install libtbb2:i386
or something like
yum install tbb.i686

After that if your server isn't starting
Check your @ExileServer/extDB/logs   for errors

1 person likes this

Share this post

Link to post
Share on other sites
  • 0


I used this and here is the log file I am getting. 

extDB2: Version: 69
extDB2: https://github.com/Torndeco/extDB2
extDB2: Windows Debug Version

Message: All development for extDB2 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB2 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 20/02/15

extDB2: Found extdb-conf.ini
extDB2: Detected 4 Cores, Setting up 4 Worker Threads

[10:31:09:559191 --7:00] [Thread 9468] extDB2: Input from Server: 9:VERSION
[10:31:09:559230 --7:00] [Thread 9468] extDB2: Output to Server: 69
[10:31:09:587970 --7:00] [Thread 9468] extDB2: Input from Server: 9:ADD_DATABASE:exile
[10:31:09:588077 --7:00] [Thread 9468] extDB2: No Config Option Found: exile
[10:31:09:588097 --7:00] [Thread 9468] extDB2: Output to Server: [0,"No Config Option Found"]
[10:31:09:588382 --7:00] [Thread 9468] extDB2: Input from Server: 9:SHUTDOWN
[10:31:09:588404 --7:00] [Thread 9468] extDB2: Sending Shutdown to Armaserver

Any idea what is going on? I know its a database issue. I have reinstalled vcredist x64 and x86 multiple times. Including uninstall restart and then install. Nothing seems to be working. Server was fine before the update, but now this. 

This is our test server on my PC running Windows 10 64bit

Thanks for the help. 

Share this post

Link to post
Share on other sites
  • 0


So I had installed vcredist multiple times with nothing. I ended up going to Microsoft and downloading vc_redist.x64 and vc_redist.x86 and this fixed the issues. 

Link to download



Not sure what the difference was but the server now starts up. Hope maybe a response to my issue will help another. 


Edited by JackalopeHuntr

Share this post

Link to post
Share on other sites
  • 0


Hello all,

I to am getting

11:15:48 "ExileServer - MySQL connection error!"
11:15:48 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
11:15:48 "ExileServer - MySQL Error: Unable to locate extDB2 extension!"
11:15:48 "ExileServer - Server will shutdown now :("


Here is the thing... I have another server running....with no issues at all.. (other than regular arma stuff..lol)

I have updated  vc_redist.x64 and vc_redist.x86 and still nothing.  The only mod I have running is MAS

my start line

start "Exile Altis PVP" /min /affinity c /realtime "C:\Users\Ryan\Desktop\exile_vanilla\arma3server3.exe" -port=2702 "-config=C:\Users\Ryan\Desktop\exile_vanilla\@ExileServer\config.cfg" "-cfg=C:\Users\Ryan\Desktop\exile_vanilla\@ExileServer\basic.cfg" "-profiles=C:\Users\Ryan\Desktop\exile_vanilla\@ExileServer" -name=default "-mod=@Exile;@ExileServer;@infiSTAR_servermod;@mas" -servermod=@ExileServer -maxMem=8192 -autoinit -loadMissionToMemory -cpuCount=4

This is how I have it set up.

I have MySQL workbench set yp with the instance I use for my games.  In that instance I have a database for the server that is currently running.  I created a new DB and pointed the @Exileserver\extdb-conf at this data base.  I have checked and recheck the syntax to make sure it is correct.. i have tried changing the case, i have tried with and without the password.  NOTHING SEEMS TO WORK.  I wouldn't say I am a noob since I have been running arma servers for about 3 years.. .however, this has got me stumped!

I have never had a DB issue like this before... Before the last update of Exile I used Xammp...connected via navicat light and just added a DB .. pointed the server instance at it.. and off I went...what am I missing here.  
Thank you all!!




It was the TBMALLOC files.. tbbmalloc.dll and tbb.dll.. They were not in the folder... UGH.. 

Edited by Rabid Panda

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.