MySQL problem!

16 posts in this topic

Hey guys,


Long story short - I own a ViLayer Exile server, what worked like a charm til the most recent update. Since that, whenever I start the server, I get the error message to update to extdb 69 - I did a full cleanup, fresh install for the server, installed extdb 69 from github, and now it says "[0,"Database Exception Error]"


I tried reinstalling the database as well, it fails to do so, and when I try to join with Heidi, it says, that it can't connect to the database address.


Any help / suggestions?


Thanks in advance! :)

Share this post

Link to post
Share on other sites

This was the first error message:



19:11:10 Client: Nonnetwork object 35468d00.
19:11:10 "ExileServer - MySQL connection error!"
19:11:10 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
19:11:10 "ExileServer - MySQL Error: Update extDB2 to version 69 or later"
19:11:10 "ExileServer - Server will shutdown now :("


The second, after installing v69:



19:38:03 "ExileServer - Server is loading..."
19:38:03 Client: Nonnetwork object 35cb8d00.
19:38:03 "ExileServer - Installed extDB2 version: 69"
19:38:04 "ExileServer - MySQL connection error!"
19:38:04 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
19:38:04 "ExileServer - MySQL Error: Could not add database: [0,"Database Exception Error"]"
19:38:04 "ExileServer - Server will shutdown now :("


The ExtDB log:


extDB2: Found extdb-conf.ini
extDB2: Detected 8 Cores, Setting up 6 Worker Threads

[19:38:03:373856 +00:-1] [Thread XXXXX] extDB2: Database Type: MySQL
[19:38:04:384890 +00:-1] [Thread XXXXX] extDB2: Database Exception Error: Connection attempt failed: Can't connect to MySQL server on 'XXXXXXXXXX' (10061)
[19:38:04:385272 +00:-1] [Thread XXXXX] extDB2: Sending Shutdown to Armaserver


The HeidiSQL error (IP removed for safety, but it's the database IP):



Can't connect to MySQL server on "XXXXXX" (10061)


When trying to reinstall database with the Vilayer tool (sensitive info removed):


*~*~*~*~*~*~*~*~*~*~*~* DATABASE MANAGER *~*~*~*~*~*~*~*~*~*~*~*
ServiceId XXXXX - Stopping XXXXXXXXX...
ServiceId XXXXX - XXXXXXXX has been stopped.
###### MySQL Reinstallation ######
Download Has Finished...
The system cannot find the file specified.
ServiceId XXXXX- Starting XXXXXXXXXX...
ServiceId XXXXX- XXXXXXXXXX has been started.
###### MySQL Reinstallation Completed ######
###### Changing MySQL Credentials ######
ServiceId XXXXX - Stopping XXXXXXXXXX...
ServiceId XXXXX - XXXXXXXXX has been stopped.
ERROR: MySQL Not Installed ... Script Aborting
The script has executed successfully. You may close this window.



Edited by Anaestheticz

Share this post

Link to post
Share on other sites

There could be a few  reasons why you couldn't connect to the database. But since it isn't throwing responses telling you it doesn't have permissions, then I'm thinking the database server for ViLayer may be down?

Has anyone tried running the following from a command prompt?

telnet <IP or address of database server for ViLayer> 3306

What response do you get?

Share this post

Link to post
Share on other sites
On 13.12.2015 at 5:44 PM, Anaestheticz said:

Meanwhile, I got an answer from ViLayer support, they know about the issue, and they're working on a fix asap.

Anaestheticz, vilayer fix MySQL problem or not for now?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.