Mikeeeyy

[FIX] Death Loop Bug

26 posts in this topic

nope, first happened on my server when clementine first came out, couple of people died just before a restart and when they logged back in they were on top of their bodies with flies buzzing around, and i implemented your fix, and deleted them from database, and everything seemed fine after that, until yesterday when this started happening, i was killed by AI and once i re-spawned i was about a minute behind where i had died, ran over killed AI and my body was there duped, so i committed suicide, re-spawned and was in my body fully geared looking at my other 2 bodies like wtf... and since then even if i delete my entry from db or start a new one it just stuck doing it, think ill rebuild the server from fresh just to see if i can repeat it, no major files have been edited apart from your fix and a few scripts that are also running on my main server, but theres no problems on that one so im major confused right now

 

Share this post


Link to post
Share on other sites
3 minutes ago, Diggz said:

nope, first happened on my server when clementine first came out, couple of people died just before a restart and when they logged back in they were on top of their bodies with flies buzzing around, and i implemented your fix, and deleted them from database, and everything seemed fine after that, until yesterday when this started happening, i was killed by AI and once i re-spawned i was about a minute behind where i had died, ran over killed AI and my body was there duped, so i committed suicide, re-spawned and was in my body fully geared looking at my other 2 bodies like wtf... and since then even if i delete my entry from db or start a new one it just stuck doing it, think ill rebuild the server from fresh just to see if i can repeat it, no major files have been edited apart from your fix and a few scripts that are also running on my main server, but theres no problems on that one so im major confused right now

 

There's definitely some kind of issue there, one my fix wont fix. Good luck man, I hope the Exile devs can find the problem.

Edited by Mikeeeyy
  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

I think i have this bug, but when i do this fix it breaks the server, everyone on the server spawns in and dies instantly, also everyone has 0 caps and respect  

Share this post


Link to post
Share on other sites
13 minutes ago, jabeds said:

I think i have this bug, but when i do this fix it breaks the server, everyone on the server spawns in and dies instantly, also everyone has 0 caps and respect  

this bug its fixed since the "pomelo" 0.9.6 Exiler Version i have never seen this bug since this version so i think you problem is another point.

Edited by Sgt. ScrapMetal

Share this post


Link to post
Share on other sites

I am running pomelo but I figured out a simple workaround for anyone else who might happen to read this.

create a new sqf file in your mission folder named death_timer_bug_temp_fix.sqf and in it write this

player allowdamage false;
sleep 20;
player allowdamage true;

At the top of the initplayerlocal.sqf file, add this

[] execVM "death_timer_bug_temp_fix.sqf";

This very simple work around gives players god mode for 20 seconds once loaded in. In theory you could change it to just a couple of seconds and it should still work (well at least for the bug I had in which player died right at the moment they left the load screen).

  • Like 1

Share this post


Link to post
Share on other sites

anyone know how to fix if u press ALT+F4 or if u fail connection to the server than when u log it u will spawn dead u will get Damage 1 soo always i need to go to database and change it again to 0 is there a way to fix  this ?

Share this post


Link to post
Share on other sites
19 hours ago, [DD] BuLi said:

anyone know how to fix if u press ALT+F4 or if u fail connection to the server than when u log it u will spawn dead u will get Damage 1 soo always i need to go to database and change it again to 0 is there a way to fix  this ?

I can fix the first one..

Ban/punish ALT-F4 users. There is no reason to use it unless you're attempting to avoid a logout timer and/or combat-logging.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.