Dodo

Vehicle Rearm

107 posts in this topic

On 9/16/2015 at 4:15 AM, Dodo said:

Hello, I have the rearm script of Axe Cop adapted to Exile. Before me, Halvhjearne has adapted it to Arma 3 Epoch.


How to install the script:

1. Copy the custom folder in your mission folder. (Exile.Altis)

2a. Modify your init.sqf and add the following: 

[] execVM "custom\money\takegive_poptab_init.sqf";

if(hasInterface) then{
    [] execVM "custom\service\service_point.sqf";
};

2b. If you do not have a init.sqf, use my and paste them in your mission folder. (Exile.Altis)

3. Now you can change the prices (Or whatever you want) in the service_point.sqf. (custom -> service)

4. It is better to remove the ammunition before buying and spawning vehicles. How To

5. Now just change the BattlEye filter and finished. How To


I have tested the script on my server. (v0.9.35)

Download Link

This does not work anymore. Does anyone know of a current working service point addon like this?

Note: I logged an issue through the github link above (https://github.com/xDodo/exile_rearm).

Thanks,
terd

Edited by Terd Fergasen

Share this post


Link to post
Share on other sites

I have modified Dodo's script to get it working, and sent him a message to see if he is happy for me to share it. Keep your eyes peeled :) although doesn't seem he has been on for quite a while.

  • Like 3

Share this post


Link to post
Share on other sites
Advertisement

Hi all,

I took a look into the code of the script and I was curious about a couple of things;

1. Does it still work on Arma 1.66? (there was an issue logged on github that it stopped working after 1.66)

2. Where do you set the ammo prices? Can you customise these?

3. If you cannot set the ammo prices, where does it get it from?



Cheers,

VirtualMechanic

PS: I tried to install the AVS rearm/refuel script but got stuck on some problems.. So I started looking into other scripts

Share this post


Link to post
Share on other sites
On 1/22/2016 at 4:03 AM, KingNirvana said:

FIX: 

If you have infistar make sure you have CAP set to false.

Also when listing the service locations make sure you dont have a extra comma at the end and try listing all the vehicles in the rearm price section manually. Fixed it for me :D

Where is this CAP option in infistar i can't seem to find it or has it changed ?

Share this post


Link to post
Share on other sites
[] execVM "custom\money\takegive_poptab_init.sqf";

if(hasInterface) then{
    [] execVM "custom\service\service_point.sqf";
};

 

This still works. Got it working last night.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.